Tsgeri 2 - 2010

Forum des tsgeri, session novembre 2009 - septembre 2010
 
AccueilAccueil  CalendrierCalendrier  FAQFAQ  RechercherRechercher  MembresMembres  GroupesGroupes  S'enregistrerS'enregistrer  Connexion  

Partagez | 
 

 besoin d'un greg :p (probleme ubuntu ^^)

Aller en bas 
AuteurMessage
YannB

avatar

Messages : 144
Date d'inscription : 22/06/2010

MessageSujet: besoin d'un greg :p (probleme ubuntu ^^)   Mer 1 Sep - 20:10

Bonjour !

Suite à une mise à jour d'ubuntu (je n'ai pas lu la maj ... j'ai juste cliquer sur installer sic !!)
Je suis obligé de démarré en mode d'affichage sans échec. (petite précision, je suis sûr ubuntu 64bits)

Je viens de voir sur le site , qu'il fallait installer les driver propriétaire nvidia par le menu systeme dans ubuntu ,
malheureusement ... j'ai installer les drivers aprés les avoir télécharger sur le site de nvidia (ça marchait trés bien comme cela depuis quelques mois)

et puis là... c'est le drame.

J'ai desinstaller mes drivers nvidia et tenter de les réinstaller par le menu Systeme (impossible, message d'erreur et je n'ai pas accés au menu driver propriétaire)
Du coup retour case départ , j'essaie d'installer mes drivers par la console.. mais cela plante au début de l'installation (probleme kernel et dépendance )

---

Petit probleme lors de : sudo apt-get install nvidia-glx-185

voici l'erreur :
Citation :
Building initial module for 2.6.32-24-generic

Error! Bad return status for module build on kernel: 2.6.32-24-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/256.52/build/ for more information.
dpkg : erreur de traitement de nvidia-current (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 10
dpkg : des problèmes de dépendances empêchent la configuration de nvidia-glx-185 :

En installant les drivers propriétaire manuellement j'ai cette erreur la au tout début de l'installation :
Citation :

ERROR: The kernel header file
'/lib/modules/2.6.32-24-generic/build/include/linux/kernel.h' does not
exist. The most likely reason for this is that the kernel source path
'/lib/modules/2.6.32-24-generic/build' is incorrect. Please make sure
you have installed the kernel source files for your kernel and that they
are properly configured; on Red Hat Linux systems, for example, be sure
you have the 'kernel-source' or 'kernel-devel' RPM installed. If you
know the correct kernel source files are installed, you may specify the
kernel source path with the '--kernel-source-path' command line option.

-------
la fameuse maj qui m'a fait planter... je suis aller regarder l'historique dans synaptique j'ai ceci :

linux-headers-2.6.32-24 (2.6.32-24.41) to 2.6.32-24.42
linux-headers-2.6.32-24-generic (2.6.32-24.41) to 2.6.32-24.42
linux-image-2.6.32-24-generic (2.6.32-24.41) to 2.6.32-24.42

--
j'ai récupére le make.log de l'installation via apt-get install nvidia-glx-185
Citation :
If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Erreur 1

si jamais vous avez une idée

merci Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ptit'd@v

avatar

Messages : 48
Date d'inscription : 23/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Ven 3 Sep - 20:50

Slt grand =)

Essaie de supprimer tt les paquets nvidia possible puis un

sudo apt-get install linux-headers-`uname-r`

E réessaie d'installer les paquets

Tiens nous au jus

shuss
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
YannB

avatar

Messages : 144
Date d'inscription : 22/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Ven 3 Sep - 23:15

eheh moi aussi je lis les forums ubuntu :p

déja fait , je vais installer débian , moins de mise à jour Twisted Evil
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
ptit'd@v

avatar

Messages : 48
Date d'inscription : 23/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Sam 4 Sep - 16:36

gnagnagna ^^ =)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
masao

avatar

Messages : 64
Date d'inscription : 23/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Lun 6 Sep - 16:24

Et n'utilise pas la merde de .run du site nvidia, cette fois...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
YannB

avatar

Messages : 144
Date d'inscription : 22/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Lun 6 Sep - 19:53

ahah , ouep j'ai su pour le .run Very Happy

du coup je suis passé sur debian lenny AMD64, On sent tout de suite le changement de philosophie (+libre et stable qu'ubuntu)
Par contre, les paquets date un peu (pas de chorium, thunderbird etc... enfin c'est idiot de les installer à l'arrache sur la version stable ^^ ) , j'aurais peut etre du installer squeeze.
Niveau configuration sur debian , tu te sens plus "aux commandes" que sur ubuntu et je trouve qu'au final c'est plus simple à configurer et propre ^^

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
masao

avatar

Messages : 64
Date d'inscription : 23/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Mar 7 Sep - 10:10

Bah ubuntu c'est pour le grand public, pas pour un administrateur technicien supérieur comme toi. Very Happy

Le problème d'ubuntu et autres distribs Mme-Michu-compliant, c'est que si tout est reconnu automatiquement dans 98% des cas, les 2% où ça ne l'est pas c'est moins évident de mettre les mains dans le cambouis...

Pour ce qui est des vieux paquets, alors effectivement là ça fait un bon moment que lenny est sortie, squeeze est actuellement en freeze (elle n'évolue plus jusqu'à ce que tous les bugs soient corrigés afin de devenir la prochaine stable).
Thunderbird s'appelle Icedove sous Debian. Firefox devient Iceweasel. Histoire de droits sur les noms et les logos, sinon c'est les mêmes...
Si tu veux garder une base stable et avoir une version récente de tel ou tel soft, tu peux faire du pinning (prendre tel ou tel paquet dans squeeze/sid en gardant les autres de lenny) ou un backport (recompiler tel ou tel paquet à partir des sources de squeeze/sid, un peu plus fiable que le pinning mais faut pas trop en abuser non plus).
Après, si c'est pour une machine de bureau, tu peux passer en sid direct. Ça reste tout de même assez stable, et les bugs sont vite corrigés. Si vraiment tu as peur, tu peux utiliser apt-listbugs pour éviter les mises-à-jour risquées...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
YannB

avatar

Messages : 144
Date d'inscription : 22/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Mar 7 Sep - 10:42

éhéh merci greg , sacré m'dam Michu
oui j'avais vu pour les logiciels mozilla avec Iceweasel et toute la click
Tu as raison, pour un pc de bureau je pense que squeeze sera plus confortable pour un usage courant.
merki !

Par contre je vais rester sur Lenny pour l'instant , si je change de distrib tous les jours , ca va etre chaud d'avoir le temps de faire le rapport de stage Very Happy

Citation :
Bah ubuntu c'est pour le grand public, pas pour un administrateur technicien supérieur comme toi. Very Happy

C'est pas bien de se moquer Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
masao

avatar

Messages : 64
Date d'inscription : 23/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Mer 8 Sep - 14:52

YannB a écrit:
Tu as raison, pour un pc de bureau je pense que squeeze sera plus confortable pour un usage courant.
Oui, mais non. La branche testing de debian est un peu « bâtarde » : tu te tapes moins de problèmes (un bon nombre de bugs sont épurés pendant le passage par sid), mais quand un paquet se trouve tout de même buggué, tu n'as aucune correction (sauf quand elle est en freeze, comme maintenant). Il faut donc attendre une prochaine mise-à-jour du paquet pour qu'il soit corrigé. Alors que sous sid, les bugs sont corrigés très vite (parfois en quelque heures !)...
De plus, c'est une branche incomplète : lorsque squeeze passera stable, la nouvelle testing (wheezy) démarrera « vide ». Il faudra alors attendre que les paquets de sid passent en testing. Donc si tu veux avoir accès à tous les paquets, il te faudra faire du pinning...

Mais faut pas avoir peur de sid juste parce que c'est écrit « unstable » hein ? C'est plus stable qu'une ubuntu...


PS : Je ne me moque que de l'intitulé de la formation...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
YannB

avatar

Messages : 144
Date d'inscription : 22/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Mer 8 Sep - 22:10

c'est noté boss Very Happy

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
masao

avatar

Messages : 64
Date d'inscription : 23/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Dim 12 Sep - 12:29

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
YannB

avatar

Messages : 144
Date d'inscription : 22/06/2010

MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   Dim 12 Sep - 15:37

ah oui mais c'est qu'à létat de projet non? Enfin ça serait vraiment excellent Laughing
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: besoin d'un greg :p (probleme ubuntu ^^)   

Revenir en haut Aller en bas
 
besoin d'un greg :p (probleme ubuntu ^^)
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» besoin de vos idées pour le syndicat.
» Besoin d'un conseil maquillage sourcil
» probleme de sommeil
» Besoin d'aide pour la dissertation
» besoin d'aide pour impôts!

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Tsgeri 2 - 2010  :: Problème informatique :: Besoin d'aide? ça se passe par ici !-
Sauter vers: